Thursday, January 31, 2013

TX Protocol Splitting Fix?

I don't know how many people have tried using Plover with the TX Protocol, but at least a few have reported that strokes get split apart. (It's a registered issue on our Github).

Hesky's attempted to write a fixed version, which can be downloaded here.

He writes: "Unfortunately, I haven't been able to reproduce the bug on my own but I've made a change that may fix the problem. If you've been experiencing splitting while using txbolt protocol with your machine, then it would be a great help if you would try this version of Plover and let me know if it fixes this problem."

If you've got a TX protocol machine, please give it a try, and let us know whether it fixed the problem. If not, more details on exactly how the splitting is happening would be very helpful.

6 comments:

Jason said...

Hi, I'm one of the people with problems.
I'll have to pull out my windows netbook so I can use the new version, since my main computer is a Mac.
I'll let you know how it goes.

Jason said...

Hello, me again.

I tried it, and it works now!

So at least for the Prowriter Plus, this solved the problem.

Thanks!

Mirabai Knight said...

Great to hear! I've passed it along to Hesky.

Anonymous said...

I got it to work a couple of times, but then the configure box is no longer showing up. I tried to see how I can import my dictionary (Stenovations DigitalCat). Any ideas for both? How to get it running again and how to import my dictionary?

Mark Crossley (signlaw@gmail.com)

Unknown said...

I've emailed Mark but if anyone else has the same questions as Mark and ends up here, the best way to get help is to email the google group: https://groups.google.com/forum/?fromgroups#!forum/ploversteno

Peter said...

I was having difficulty with another version of Plover recognizing my dictionary using the student elan Cybra; although using a Sidewinder X4 keyboard was not a problem. This evening, I decided to try this version, and the program worked quite well.

Many thanks!